Index of /japache/dist/ant

Icon  Name                     Last modified      Size  Description
[DIR] Parent Directory - [   ] KEYS 15-Dec-2003 00:00 17K [TXT] RELEASE-NOTES-1.7.1.html 09-Jul-2008 00:00 8.2K [DIR] antlibs/ 11-Jul-2012 22:41 - [DIR] binaries/ 11-Jul-2012 22:41 - [DIR] common/ 11-Jul-2012 22:41 - [DIR] ivy/ 11-Jul-2012 22:42 - [DIR] ivyde/ 11-Jul-2012 22:42 - [DIR] source/ 11-Jul-2012 22:42 -

Ant 1.5.4

This is the 1.5.4 version of Ant. It is available in both binary and source distributions.

JDK 1.1 Users:

Please note that the next major release of Ant, Ant 1.6, will require JDK 1.2 or later. This release, Ant 1.5.4, will be the last Ant release from the Ant 1.5 codebase, barring any major bugs. As such, it is likely to be the last release of Ant that will be JDK 1.1 compatible. Ant 1.6, of course, retains the ability to generate 1.1 compatible code.

Note: The tar files in the distribution use GNU tar extensions and must be untarred with a GNU compatible version of tar. The version of tar on Solaris and Mac OS X will not work with these files

Changes

The changes from Release 1.5.3 to this release are detailed below. Please refer to the WHATSNEW file for more information.

Thank you for using Ant.

The Apache Ant Project
http://ant.apache.org/

PGP Signatures

Many of the distribution kits have been digitally signed (using PGP). If so, there will be an accompanying distribution.asc file in the same directory as the distribution. The PGP keys can be found in the distribution directory at <http://www.apache.org/dist/ant/KEYS>.

Always test available signatures, e.g.,
> pgpk -a KEYS
> pgpv apache-ant-1.5.4-bin.tar.gz.asc
or,
> pgp -ka KEYS
> pgp apache-ant-1.5.4-bin.tar.gz.asc
or,
> gpg --import KEYS
> gpg --verify apache-ant-1.5.4-bin.tar.gz.asc

Changes from Ant 1.5.3 to Ant 1.5.4

Changes that could break older environments:

Fixed bugs:

Other Changes: